Social Icons

Print Friendly and PDF

Thursday, May 31, 2012

Fedora vs CentOS

End of era for my Fedora based server after almost five years of service. The box now runs CentOS. I had this box at home and it was the only Fedora Server I ever maintained at home or elsewhere. I should state from the beginning that it was only Fedora’s short life-cycle that practically forced me to switch. Other than that, I’ve never encountered a single issue with its performance, stability or security, even if I had been upgrading through yum since Fedora Core 3 (upgrading through yum is probably still an officially unsupported feature).

You have probably read several times on this website about the stability issues I had faced on my Fedora Desktop. All those issues were entirely related to graphical applications and are common among all Linux distributions that are used as desktop operating systems. There is a huge gap in quality between the software that is used to run a WWW, SMTP, FTP, et cetera server and the software that is used on Linux desktops. Anyway, I won’t go into the details of this topic in the current post. I would like to say only this: If Fedora’s short life-cycle and the frequent updates are not a problem to you, then Fedora automatically becomes a very strong candidate for your server.
Having used Red Hat Linux, CentOS and Fedora over time I have finally come to several conclusions about each of them (well RHL has reached EOL). Below, I try to summarize the advantages and downsides of each of the last two distributions both as an operating system for a server and as a project to which you might want to contribute (since you use it on your boxes):

CentOS

Advantages:
  • Almost guaranteed stability. The distribution includes old but proven versions of software which are very unlikely to have serious security or blocker bugs. “Almost” is used because you get true guaranteed stability only by using Red Hat Enterprise Linux (RHEL), which is available under contract by Red Hat Inc.
  • The CentOS or better the RHEL Life-Cycle is 7 years.
Disadvantages:
  • The included software on the base repositories does not fully cover the needs of a modern server. Using software from 3rd party repositories has become a common practice among CentOS users. There are some well-known repositories, but it may happen that you have to use a package from a repository that is not so popular or (many times) completely unknown. Using software from 3rd party repositories renders your installation less secure.
  • If a bug is not security-related, it may take several months (sometimes more than a year) to get fixed. Although the sources are the same with RHEL, except for the artwork, logos and release notes, CentOS has its own bug tracking system, which is completely unrelated to the Red Hat bug tracking system, meaning that they do not monitor or notify each other for bug submissions and fixes, despite the fact that the two OSes are almost alike. In practice, this is worse than it sounds. Things *could* be better.
  • The organization of the community behind CentOS is not very clear. Even if you want to contribute some time and effort you will have to accept some things “as is”. In general, it is nowhere near the organization and openness of the Fedora community.
  • CentOS does not differ from the vast majority of Linux distributions when it comes to your relationship as a contributor to the project, which is mostly governed by “bro” rules and practices.

Fedora

Advantages:
  • Software availability. The project’s repositories contain a huge amount of packages, which have been built with common, well-documented packaging guidelines. Almost any software a modern server may require can be found in the main RPM repository. Only in rear occasions you will need a 3rd party repo.
  • A well-organized community around the project. All procedures are open and well-documented.
  • Professional procedures and practices govern your relationship to the project as a contributor.
  • Bugs are resolved rather quickly, especially blocker bugs.
Disadvantages:
  • Short life-cycle of about 13 months.
  • Theoritically, less stable versions of software than CentOS or RHEL. Even the server software is updated too often. Despite of the high quality of the server software, the frequent updates makes it “feel” less stable. From my own experience though, I’d say that, if CentOS gets an “100% Stable” label, a Fedora Server gets a 99.5%. Personally, although I had set up several services on the box, I never had any stability issues, but that does not necessarily mean that they do not exist.
As you can see, both distributions have their downsides. Now that I have written all the above, I think that there is a gap between the two OSes, which could be filled by a 3rd operating system. A system that would be more modern than CentOS, but less “cutting edge” than Fedora, and which would have a life-cycle of about 3-4 years. That would be very interesting.
Personally, I have successfully used both operating systems as servers for several years. I cannot make up my mind and decide which one better meets a server’s requirements. As I have previously mentioned, I decided to fully switch to CentOS because of the significantly longer life-cycle.

Authors g-loaded.eu

Saturday, May 19, 2012

Setting dan Configuration Access Point on Mikrotik Device Via Winbox

Access Point is a place that became the center of several connections are connected. This tool is also known as Cross Box. If viewed from the standpoint of a phone connection, the Access Point is a box where the phone cord from the telephone subscribers are connected. Function of the Access Point is a Hub / Switch which acts to connect a local network with a wireless network / wireless its clients


The Function of Access Point supposing as a Hub / Switch on the local network, which acts to connect the local network with a wireless network / wireless clients / your neighbors, at this access point internet connection from where you are emitted or transmitted via radio waves, the strength of the signal is also affecting to the area will be covered, the higher of signal strength (size in units of dBm or mW) as long as wider scope.


In this article will describe how to setting up and how to configure Access Point at the Mikrotik Via Winbox. Here are step by step to configure Access Point at the Mikrotik Using Winbox Application.


Login to your Mikrotik Device from Mac Address Device or Ip address Via Winbox Application, to see detail look at the picture below:Look first at the interface tab from the menu Winbox ... .. whatever there and active, there will usually appears interfaces Ether1, ether2, ether3 and subsequently as well as interface Wlan1, wlan2 and beyond. Choose which interface you use. Then start doing the configuration settings on Mikrotik Access Point.

In this section, We illustrate only 1 (one) interface that is ether1 ether and 1 (one) Interface wlan1. Ether1 is the path that we will connect with the Local Network and wlan1 is the path that we will connect with the wireless network / our wireless clients. Two of these interfaces that we use for setting Access Point at the Mikrotik Device.Langkah selanjutnya Setting IP Address
Ip untuk interface ether1 adalah ip untuk menyambungkan ke jaringan local, dan ip untuk interface wlan1 adalah untuk menghubungkan ke jaringan wireless/wireless clients. Sebagai contoh setting ip pada kedua ionterface tersebut adalah sebagai berikut:

Next Step is Setting an IP Address
Ip for interface ether1 is to connect with the local network, and IP for interface wlan1 is ip to connect with wireless network / wireless clients. For example in both interface ip settings are as follows:

Menu Winbox:
IP…Address…Add
Ip for interface ether1: 10.xx.xx.xx/27
Ip untuk interface wlan1: 10.xx.xx.xx/30Next step are set the Gateway that we will use
Menu Winbox:
IP--------Routes----Add
For Example Ip Gateway: 114.xx.xx.xxAdding Bridge, that is a way to extend or connect two or more (multiple), ethernet / network segment

Menu Winbox:
Bridge…..Bridges…addAdding and setting Tunnel Eoip, ie components that can function in a transparent bridge to a remote network.

Menu Winbox:
Interface……Add….Eoip Tunnel
For detail see picture below:Setting Port Bridge
Port that will be on the bridge so that can be connected with local networks and wireless networks / wireless client that is Eoip Tunnel and ether1.

Menu Winbox:
Bridge…..Ports….Add…
See picture for detailsSetting and configuration Access Point on the mikrotik device has been completed and is ready to be connected with Wireless Networking / Wireless client.

Go to Winbox and look at the tab menu on Wireless, enabling interface wlan1 if these interface is not enabled. Double click on the wlan1 interface and setting it, and connect it with your wireless network / wireless clients that you've prepared. See picture Below:

Authors reviewsdaily.blogspot.com

Wednesday, May 2, 2012

Cisco IOS Router Commands

Routing with Cisco 2500 and 1000 Series for LAN-ISDN Service

Commands - General

There are 3 different modes of operation within the Cisco IOS.
  1. Disabled mode
  2. Enabled mode
  3. Configuration mode
In the Disabled mode you can use a limited number of commands. This is used primarily to monitor the router.
The Enabled mode is used to show configuration information, enter the configuration mode, and make changes to the configuration.
The Configuration mode is used to enter and update the runtime configuration.
To get a list of the commands for the cisco type '?' at the prompt. To get further information about any command, type the command followed by a '?'.
clear Reset functions
clock Manage the system clock
configure Enter configuration mode
debug Debugging functions (see also 'undebug')
disable Turn off privileged commands
enable Turn on privileged commands
erase Erase flash or configuration memory
exit Exit from the EXEC
help Description of the interactive help system
login Log in as a particular user
logout Exit from the EXEC
no Disable debugging functions
ping Send echo messages
reload Halt and perform a cold restart
setup Run the SETUP command facility
show Show running system information
telnet Open a telnet connection
terminal Set terminal line parameters
test Test subsystems, memory, and interfaces
traceroute Trace route to destination
tunnel Open a tunnel connection
undebug Disable debugging functions (see also 'debug')
verify Verify checksum of a Flash file
write Write running configuration to memory, network, or terminal

show
access-lists List access lists
arp ARP table
buffers Buffer pool statistics
configuration Contents of Non-Volatile memory
controllers Interface controller status
debugging State of each debugging option
dialer Dialer parameters and statistics
extended Extended Interface Information
flash System Flash information
flh-log Flash Load Helper log buffer
history Display the session command history
hosts IP domain-name, lookup style, name servers, and host table
interfaces Interface status and configuration
ip IP information
isdn ISDN information
line TTY line information
logging Show the contents of logging buffers
memory Memory statistics
privilege Show current privilege level
processes Active process statistics
protocols Active network routing protocols
queue Show queue contents
queueing Show queueing configuration
reload Scheduled reload information
route-map route-map information
running-config Current operating configuration
sessions Information about Telnet connections
smf Software MAC filter
stacks Process stack utilization
startup-config Contents of startup configuration
subsys Show subsystem information
tcp Status of TCP connections
terminal Display terminal configuration parameters
users Display information about terminal lines
version System hardware and software status

Other Useful Commands

View the Software Version
View the Ethernet IP
View the Serial IP
View the Default Route
View the Filters
View the Bandwidth
Add a Static Route
Change the Dial Number
Turn Filters On and Off
Ping from the Router
Traceroute from the Router

View the Software Version

Cisco>en
Cisco#wr term    <--- Shows the running configuration    
Building configuration...
Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Cisco
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.6.1 255.255.255.0
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial1
 ip address 192.168.4.2 255.255.255.0
 encapsulation frame-relay
 bandwidth 1536
 keepalive 5
 frame-relay map ip 192.168.4.1 101 IETF
!
router rip
 version 2
 network 192.168.4.0
 network 192.168.6.0
 neighbor 192.168.6.2
 neighbor 192.168.4.1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.6.2
ip route 0.0.0.0 0.0.0.0 192.168.4.1
!
line con 0
line aux 0
line vty 0 4
login
!
end

View the Ethernet IP

Router#wr term


This will show the running configuration.
Within the configuration, you will see an interface ethernet 0 section:


interface Ethernet0
ip address 38.150.93.1 255.255.255.0
no ip directed-broadcast

View the Serial IP

Router#wr term


Within the configuration, you will see an interface serial 0 section:


interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

View the Default Route

Router#wr term


Within the configuration, you will see an ip route section. 


In the ip route section, look for a route:
ip route 0.0.0.0 0.0.0.0 38.167.29.1
The last ip address is the POP ip.

View the Filters

Router#wr term


Under interface serial 0, look for:


ip access-group 104 in
ip access-group 105 out


This means that access-group 104 is the inbound filter set and
access-group 105 is the outbound filter set.
Then, continue to look in the configuration for the access-list statements:


(Example access-list statements)
access-list 104 deny   ip 38.166.101.0 0.0.0.255 any
access-list 104 permit tcp any any established
access-list 104 permit tcp any eq ftp-data any gt 1023
access-list 104 permit udp any eq domain any gt 1023
access-list 104 permit udp any eq domain any eq domain
access-list 104 permit icmp any any
access-list 104 permit udp any eq snmp any gt 1023
access-list 105 deny   ip any 38.166.101.0 0.0.0.255
access-list 105 permit tcp any any established
access-list 105 permit tcp any any eq ftp
access-list 105 deny   udp any eq netbios-ns any
access-list 105 deny   udp any eq netbios-dgm any
access-list 105 permit ip any any

View the Bandwidth

Router#wr term


Within the config, you will see an interface serial 0 section:


interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

Add a Static Route

Cisco#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Cisco(config)#ip route DEST.DEST.DEST.DEST MASK.MASK.MASK.MASK GATE.GATE.GATE.GATE
where: DEST.DEST.DEST.DEST = The destination network the static route is for
       MASK.MASK.MASK.MASK = The subnet mask of the destination network
       GATE.GATE.GATE.GATE = The gateway of the static route
Example route statement:
ip route 38.222.75.0 255.255.255.0 38.20.5.1
Cisco(config)#^Z (hit <control> z)


Write the entry to memory:


Cisco#wr mem
Building configuration...
[OK]

Change the Dial Number

Type en to put the router in enable mode:


test.com>en


The password should be the same as the one used to telnet in.


Password:


To view the router's configuration, type:


test.com#show config


There will be a line in the configuration that says:


dialer map IP 38.1.1.1 speed 64 name LD3330 2707000


The 2707000 is the dial number.


NOTE: Record what interface the dialer map IP line is under because you will need to 
use that interface when changing the number.


Type config t to configure from terminal.


test.com#config t


Enter configuration commands, one per line.  End with CNTL/Z.
Enter the interface that the dialer map IP line is under:


test.com(config)#interface BRI0


Add in the new dialer map IP line with the new phone number:


test.com(config)#dialer map IP 38.1.1.1 speed 64 name LD3330 [new number]


Now, remove the old dialer map IP line.
To remove a line, type no and then the line.
For example, to remove the old dialer map IP, type:


test.com(config)#no dialer map IP 38.1.1.1 speed 64 name LD3330 2707020


Now leave config mode:


test.com(config)# [control] z


Save changes:


test.com# write mem
Building configuration...
[OK]


Verify the new number is in the config:


test.com#show config


The new number should be in the dialer map IP line.

Turn Filters On and Off

To turn the filters off:


Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#no ip access-group 104 in
Router(config-if)#no ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#


To turn the filters on:


Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#ip access-group 104 in
Router(config-if)#ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#

Ping from the Router

Cisco#ping <hostname>
Example:
Cisco#ping 38.8.14.2

 Authors www.tomax7.com